aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/iproute2
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadupstream-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
upstream-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
upstream-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 3aa46bb838..645d0349f4 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -55,13 +55,13 @@ define Build/Compile
endef
define Package/ip/install
- install -d -m0755 $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
endef
define Package/tc/install
- install -d -m0755 $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,ip))