aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-07 12:37:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-07 12:37:49 +0000
commitfe596f2c95120b540e5a645eed464e853d55acc0 (patch)
tree44b73584666f7c005ea8935c1b91ae280c680b2b /package/iproute2
parentbcf772116464cb5ab7bfe93075e47a6078ac68ad (diff)
downloadupstream-fe596f2c95120b540e5a645eed464e853d55acc0.tar.gz
upstream-fe596f2c95120b540e5a645eed464e853d55acc0.tar.bz2
upstream-fe596f2c95120b540e5a645eed464e853d55acc0.zip
iproute2: fix build errors with newer versions of eglibc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 640b5658fd..80681f5577 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -63,6 +63,12 @@ define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
+ifdef CONFIG_USE_EGLIBC
+ ifndef CONFIG_EGLIBC_VERSION_2_13
+ TARGET_CFLAGS += -DHAVE_SETNS
+ endif
+endif
+
MAKE_FLAGS += \
EXTRA_CCOPTS="$(TARGET_CFLAGS) -I../include -I$(STAGING_DIR)/usr/include/libnl-tiny" \
KERNEL_INCLUDE="$(LINUX_DIR)/include" \