aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-14 01:56:33 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-14 01:56:33 +0000
commitef11d8626cc0b1bd642898647a6593467863a6c5 (patch)
treeb9467cde1d8625bcd853cdf58f856875a669e941 /package/iproute2
parentb6371cfd14c67ad114143200c2d4511446799511 (diff)
downloadupstream-ef11d8626cc0b1bd642898647a6593467863a6c5.tar.gz
upstream-ef11d8626cc0b1bd642898647a6593467863a6c5.tar.bz2
upstream-ef11d8626cc0b1bd642898647a6593467863a6c5.zip
this patches fixes iproute2 parallel build.
-Raphael git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20189 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index c7c3e2be5a..9eec69e41c 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=2.6.29-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
@@ -48,7 +48,7 @@ define Build/Configure
$(SED) "s,^LIBC_INCLUDE.*,LIBC_INCLUDE=$(STAGING_DIR)/include," \
$(PKG_BUILD_DIR)/Makefile
# For now disable compiling of the misc directory because it seems to fail
- rm -rf $(PKG_BUILD_DIR)/misc
+ rm -rf $(PKG_BUILD_DIR)/misc
$(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
endef
@@ -59,8 +59,8 @@ MAKE_FLAGS += \
all tc/tc ip/ip
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
- $(Build/Compile/Default)
+ $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
+ $(_SINGLE)$(Build/Compile/Default)
endef
define Build/InstallDev
@@ -90,5 +90,3 @@ endef
$(eval $(call BuildPackage,ip))
$(eval $(call BuildPackage,tc))
$(eval $(call BuildPackage,genl))
-
-