aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-05 11:01:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-05 11:01:44 +0000
commitb3c236efccceeda1e2d34a0d8550a651ce8057b6 (patch)
treebf3913b08645c337196440e2b4ae6aabed41ccb6 /package/iproute2
parent8f33d392f4688a39cc45e7ef8b6de77318ff3a38 (diff)
downloadupstream-b3c236efccceeda1e2d34a0d8550a651ce8057b6.tar.gz
upstream-b3c236efccceeda1e2d34a0d8550a651ce8057b6.tar.bz2
upstream-b3c236efccceeda1e2d34a0d8550a651ce8057b6.zip
Require* calls must now be placed before BuildPackage calls
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15620 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index a05f0cdfe1..5ce9083e38 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -74,10 +74,12 @@ define Package/genl/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
endef
+$(eval $(call RequireCommand,bison, \
+ $(PKG_NAME) requires GNU bison. \
+))
+
$(eval $(call BuildPackage,ip))
$(eval $(call BuildPackage,tc))
$(eval $(call BuildPackage,genl))
-$(eval $(call RequireCommand,bison, \
- $(PKG_NAME) requires GNU bison. \
-))
+