aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-05 22:29:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-05 22:29:14 +0000
commit4ae67d3a1c965fe55911f7432752650a5b37281f (patch)
tree67ebe5097f0aca9171fe315a6dbc6cb6c3be1ec3 /package/iproute2
parent50dcc22634a1b8db648875bd54788e8af3068bf5 (diff)
downloadupstream-4ae67d3a1c965fe55911f7432752650a5b37281f.tar.gz
upstream-4ae67d3a1c965fe55911f7432752650a5b37281f.tar.bz2
upstream-4ae67d3a1c965fe55911f7432752650a5b37281f.zip
iproute2: compile the static libraries with $(FPIC), as they are reused by other packages for inclusion into shared libraries
should fix collectd build failures on mips git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18323 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index b36b95bc9b..a3b5f471cf 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -51,9 +51,15 @@ define Build/Configure
$(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
endef
+MAKE_FLAGS += \
+ EXTRA_CCOPTS="$(TARGET_CFLAGS)" \
+ KERNEL_INCLUDE="$(LINUX_DIR)/include" \
+ FPIC="$(FPIC)" \
+ all tc/tc ip/ip
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/netem HOSTCC="$(HOSTCC)" EXTRA_CCOPTS="$(TARGET_CFLAGS)" CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
- $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) EXTRA_CCOPTS="$(TARGET_CFLAGS)" KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
+ $(Build/Compile/Default)
endef
define Build/InstallDev