aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-06-11 09:30:23 +0000
committerSteven Barth <steven@midlink.org>2013-06-11 09:30:23 +0000
commit37d5e6aca949becbda0e0ea387518dd45136e24c (patch)
treeb863ff76f1f6e758da41d89696463aa41c44a386 /package/iproute2
parentfbbdd37b2e8541c2ac795955bd9f549b004ad14d (diff)
downloadupstream-37d5e6aca949becbda0e0ea387518dd45136e24c.tar.gz
upstream-37d5e6aca949becbda0e0ea387518dd45136e24c.tar.bz2
upstream-37d5e6aca949becbda0e0ea387518dd45136e24c.zip
AA: iproute2: Backport r36910
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36912 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile2
-rw-r--r--package/iproute2/patches/900-drop_FAILED_POLICY.patch60
2 files changed, 61 insertions, 1 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 8e89617e12..79d5797809 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=3.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
diff --git a/package/iproute2/patches/900-drop_FAILED_POLICY.patch b/package/iproute2/patches/900-drop_FAILED_POLICY.patch
new file mode 100644
index 0000000000..d96eff6518
--- /dev/null
+++ b/package/iproute2/patches/900-drop_FAILED_POLICY.patch
@@ -0,0 +1,60 @@
+From 4e7dbf76227e8c7be7897dc81def3011f637864d Mon Sep 17 00:00:00 2001
+From: Jonas Gorski <jogo@openwrt.org>
+Date: Thu, 30 May 2013 11:54:04 +0200
+Subject: [PATCH] add support for dropping with FAILED_POLICY
+
+---
+ include/linux/fib_rules.h | 4 ++++
+ include/linux/rtnetlink.h | 1 +
+ ip/rtm_map.c | 4 ++++
+ 3 files changed, 9 insertions(+)
+
+Index: iproute2-3.3.0/include/linux/fib_rules.h
+===================================================================
+--- iproute2-3.3.0.orig/include/linux/fib_rules.h 2013-06-10 15:48:46.771045967 +0200
++++ iproute2-3.3.0/include/linux/fib_rules.h 2013-06-10 15:48:46.763045967 +0200
+@@ -64,6 +64,10 @@
+ FR_ACT_BLACKHOLE, /* Drop without notification */
+ FR_ACT_UNREACHABLE, /* Drop with ENETUNREACH */
+ FR_ACT_PROHIBIT, /* Drop with EACCES */
++ FR_ACT_RES8,
++ FR_ACT_RES9,
++ FR_ACT_RES10,
++ FR_ACT_FAILED_POLICY, /* Drop with EPERM */
+ __FR_ACT_MAX,
+ };
+
+Index: iproute2-3.3.0/include/linux/rtnetlink.h
+===================================================================
+--- iproute2-3.3.0.orig/include/linux/rtnetlink.h 2013-06-10 15:48:46.771045967 +0200
++++ iproute2-3.3.0/include/linux/rtnetlink.h 2013-06-10 15:48:46.763045967 +0200
+@@ -191,6 +191,7 @@
+ RTN_THROW, /* Not in this table */
+ RTN_NAT, /* Translate this address */
+ RTN_XRESOLVE, /* Use external resolver */
++ RTN_FAILED_POLICY, /* Source address failed policy */
+ __RTN_MAX
+ };
+
+Index: iproute2-3.3.0/ip/rtm_map.c
+===================================================================
+--- iproute2-3.3.0.orig/ip/rtm_map.c 2013-06-10 15:48:46.771045967 +0200
++++ iproute2-3.3.0/ip/rtm_map.c 2013-06-10 15:48:46.763045967 +0200
+@@ -49,6 +49,8 @@
+ return "nat";
+ case RTN_XRESOLVE:
+ return "xresolve";
++ case RTN_FAILED_POLICY:
++ return "failed_policy";
+ default:
+ snprintf(buf, len, "%d", id);
+ return buf;
+@@ -84,6 +86,8 @@
+ res = RTN_UNICAST;
+ else if (strcmp(arg, "throw") == 0)
+ res = RTN_THROW;
++ else if (strcmp(arg, "failed_policy") == 0)
++ res = RTN_FAILED_POLICY;
+ else {
+ res = strtoul(arg, &end, 0);
+ if (!end || end == arg || *end || res > 255)