aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-05-26 21:58:24 +0000
committerNicolas Thill <nico@openwrt.org>2009-05-26 21:58:24 +0000
commit1a8d26f5807ac580d4bc32696fb42e2250cba2cd (patch)
tree0666ab5f79781955e10121440e32412bbdaebd93 /package/iproute2
parentf819e0997543d18725932a56900fec0043c212cc (diff)
downloadupstream-1a8d26f5807ac580d4bc32696fb42e2250cba2cd.tar.gz
upstream-1a8d26f5807ac580d4bc32696fb42e2250cba2cd.tar.bz2
upstream-1a8d26f5807ac580d4bc32696fb42e2250cba2cd.zip
[package] iproute2: install netlink header and library
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16100 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 4fd34f20bb..a5d90f5a58 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -57,6 +57,13 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/include/libnetlink.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
+endef
+
define Package/ip/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_DIR) $(1)/etc/iproute2