aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2/patches/006-iproute2-tc_esfq.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-02 20:29:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-02 20:29:22 +0000
commit4482f4b5f127fbccfc9771d68617bffd47b49a27 (patch)
treef1f61a3c527cce423a9e04334219579bd283159f /package/iproute2/patches/006-iproute2-tc_esfq.patch
parent6f7e2d4ce83faf8ff9c6694cf5537ef0402a5319 (diff)
downloadupstream-4482f4b5f127fbccfc9771d68617bffd47b49a27.tar.gz
upstream-4482f4b5f127fbccfc9771d68617bffd47b49a27.tar.bz2
upstream-4482f4b5f127fbccfc9771d68617bffd47b49a27.zip
iproute2: dont filter cached routes on iproute_get (#8339)
SVN-Revision: 24216
Diffstat (limited to 'package/iproute2/patches/006-iproute2-tc_esfq.patch')
-rw-r--r--package/iproute2/patches/006-iproute2-tc_esfq.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/iproute2/patches/006-iproute2-tc_esfq.patch b/package/iproute2/patches/006-iproute2-tc_esfq.patch
index 8546ef6a4d..65dbc4f556 100644
--- a/package/iproute2/patches/006-iproute2-tc_esfq.patch
+++ b/package/iproute2/patches/006-iproute2-tc_esfq.patch
@@ -4,8 +4,8 @@
tc/q_esfq.c | 200 ++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 260 insertions(+)
---- iproute2-2.6.35.orig/include/linux/pkt_sched.h
-+++ iproute2-2.6.35/include/linux/pkt_sched.h
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
@@ -174,8 +174,38 @@ struct tc_sfq_qopt
*
* The only reason for this is efficiency, it is possible
@@ -83,8 +83,8 @@
/* RED section */
enum {
---- iproute2-2.6.35.orig/tc/Makefile
-+++ iproute2-2.6.35/tc/Makefile
+--- a/tc/Makefile
++++ b/tc/Makefile
@@ -8,6 +8,7 @@ SHARED_LIBS ?= y
TCMODULES :=
TCMODULES += q_fifo.o
@@ -94,7 +94,7 @@
TCMODULES += q_prio.o
TCMODULES += q_tbf.o
--- /dev/null
-+++ iproute2-2.6.35/tc/q_esfq.c
++++ b/tc/q_esfq.c
@@ -0,0 +1,200 @@
+/*
+ * q_esfq.c ESFQ.