aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-10 19:06:22 +0000
committerMike Baker <mbm@openwrt.org>2006-05-10 19:06:22 +0000
commit4db966cb5e50b72afbb0b0b9ea0176b78f4e9064 (patch)
tree723775516af9d2f501e52b4cbccb4b00f52ce5a9 /package/iproute2/Makefile
parenta9b90461ebdaeec297893bb2357a5785424f5844 (diff)
downloadupstream-4db966cb5e50b72afbb0b0b9ea0176b78f4e9064.tar.gz
upstream-4db966cb5e50b72afbb0b0b9ea0176b78f4e9064.tar.bz2
upstream-4db966cb5e50b72afbb0b0b9ea0176b78f4e9064.zip
Convert packages to new template
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3752 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iproute2/Makefile')
-rw-r--r--package/iproute2/Makefile58
1 files changed, 39 insertions, 19 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index f829293f4a..0fe03bc825 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -5,19 +5,38 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=2.6.15-060110
PKG_RELEASE:=1
-PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
+PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
PKG_CAT:=zcat
include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,IP,ip,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,TC,tc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+# define Package/iproute2
+# SECTION:=base
+# CATEGORY:=Network
+# DEFAULT:=n
+# MENU:=1
+# TITLE:=A collection of utilites for controlling TCP/IP networking and Traffic Control
+# endef
+
+define Package/ip
+SECTION:=base
+CATEGORY:=Network
+DEFAULT:=n
+DEPENDS:=iproute2
+TITLE:=A routing control utility
+endef
+
+define Package/tc
+$(call Package/ip)
+# DEPENDS:=kmod-sched
+TITLE:=A traffic control utility
+endef
-$(PKG_BUILD_DIR)/.configured:
+define Build/Configure
$(SED) "s:-O2:${TARGET_CFLAGS}:g" $(PKG_BUILD_DIR)/Makefile
$(SED) "s,-I/usr/include/db3,," $(PKG_BUILD_DIR)/Makefile
$(SED) "s,^KERNEL_INCLUDE.*,KERNEL_INCLUDE=$(LINUX_DIR)/include," \
@@ -27,22 +46,23 @@ $(PKG_BUILD_DIR)/.configured:
# For now disable compiling of the misc directory because it seems to fail
rm -rf $(PKG_BUILD_DIR)/misc
$(SED) "s, misc,," $(PKG_BUILD_DIR)/Makefile
- touch $@
+endef
-$(PKG_BUILD_DIR)/.built:
+define Build/Compile
$(MAKE) -j1 -C $(PKG_BUILD_DIR)/netem HOSTCC=$(HOSTCC) CFLAGS="-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -I ../include -DRESOLVE_HOSTNAMES"
$(MAKE) -j1 -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
- touch $@
+endef
-$(IPKG_IP):
- mkdir -p $(IDIR_IP)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/ip/ip $(IDIR_IP)/usr/sbin/
- $(STRIP) $(IDIR_IP)/usr/sbin/*
- $(IPKG_BUILD) $(IDIR_IP) $(PACKAGE_DIR)
+define Package/ip/install
+ install -d -m0755 $(IDIR_IP)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/ip/ip $(IDIR_IP)/usr/sbin/
+endef
-$(IPKG_TC):
- mkdir -p $(IDIR_TC)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/tc/tc $(IDIR_TC)/usr/sbin/
- $(STRIP) $(IDIR_TC)/usr/sbin/*
- $(IPKG_BUILD) $(IDIR_TC) $(PACKAGE_DIR)
+define Package/tc/install
+ install -d -m0755 $(IDIR_TC)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/tc/tc $(IDIR_TC)/usr/sbin/
+endef
+# $(eval $(call BuildPackage,iproute2))
+# $(eval $(call BuildPackage,ip))
+# $(eval $(call BuildPackage,tc))