aboutsummaryrefslogtreecommitdiffstats
path: root/package/iperf
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
commit155d58c6931397ed9543025e575d6bfa49393b8a (patch)
tree83edc5498ee98c1daa5a6004ba12e88480bcf24e /package/iperf
parentaf1954612ad08f63290c883b5ee3be8107f8f995 (diff)
downloadupstream-155d58c6931397ed9543025e575d6bfa49393b8a.tar.gz
upstream-155d58c6931397ed9543025e575d6bfa49393b8a.tar.bz2
upstream-155d58c6931397ed9543025e575d6bfa49393b8a.zip
build c++ sources without rtti
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2271 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iperf')
-rw-r--r--package/iperf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/iperf/Makefile b/package/iperf/Makefile
index a4816a629c..0eaf302556 100644
--- a/package/iperf/Makefile
+++ b/package/iperf/Makefile
@@ -20,8 +20,8 @@ $(PKG_BUILD_DIR)/.configured:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -nostdinc++ -nodefaultlibs" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
+ LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-luClibc++ -lc -lm -lgcc_s" \
ac_cv_func_malloc_0_nonnull=yes \
./configure \