aboutsummaryrefslogtreecommitdiffstats
path: root/package/ipcad
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2005-12-17 17:19:53 +0000
committerFlorian Fainelli <florian@openwrt.org>2005-12-17 17:19:53 +0000
commit237d41ae15f2295d2f679a2aeb372b076b663da2 (patch)
treede11e99bfa42ff126b777d9105c4e80fa52d7d54 /package/ipcad
parent5744a07992c43d7592b393957b08be7f17ebbefa (diff)
downloadupstream-237d41ae15f2295d2f679a2aeb372b076b663da2.tar.gz
upstream-237d41ae15f2295d2f679a2aeb372b076b663da2.tar.bz2
upstream-237d41ae15f2295d2f679a2aeb372b076b663da2.zip
Added ipcad
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2714 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ipcad')
-rwxr-xr-xpackage/ipcad/Config.in10
-rwxr-xr-xpackage/ipcad/Makefile53
-rwxr-xr-xpackage/ipcad/ipkg/ipcad.control6
3 files changed, 69 insertions, 0 deletions
diff --git a/package/ipcad/Config.in b/package/ipcad/Config.in
new file mode 100755
index 0000000000..c38731f9c4
--- /dev/null
+++ b/package/ipcad/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_IPCAD
+ tristate "ipcad............................. listens for traffic on the specified interfaces"
+ default m if CONFIG_DEVEL
+ select BR2_PACKAGE_LIBPCAP
+ help
+ This daemon listens for traffic on the specified interfaces.
+ It has the built-in RSH and NetFlow engines to allow exporting
+ the accounting data the same way as Cisco routers do.
+
+ http://lionet.info/ipcad/
diff --git a/package/ipcad/Makefile b/package/ipcad/Makefile
new file mode 100755
index 0000000000..f49ac7ef8c
--- /dev/null
+++ b/package/ipcad/Makefile
@@ -0,0 +1,53 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ipcad
+PKG_VERSION:=3.7
+PKG_RELEASE:=1
+PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
+PKG_SOURCE_URL:=@SF/ipcad
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IPCAD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --program-prefix="" \
+ --with-gnu-ld \
+ --with-psrc=pcap \
+ --with-pcap-include=$(STAGING_DIR)/usr/include \
+ --with-pcap-libraries=$(STAGING_DIR)/usr/lib \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install-bin install-conf
+ touch $@
+
+$(IPKG_IPCAD):
+ mkdir -p $(IDIR_IPCAD)
+ cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_IPCAD)/
+ $(RSTRIP) $(IDIR_IPCAD)
+ $(IPKG_BUILD) $(IDIR_IPCAD) $(PACKAGE_DIR)
diff --git a/package/ipcad/ipkg/ipcad.control b/package/ipcad/ipkg/ipcad.control
new file mode 100755
index 0000000000..93df70c1d5
--- /dev/null
+++ b/package/ipcad/ipkg/ipcad.control
@@ -0,0 +1,6 @@
+Package: ipcad
+Depends: libpcap
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: IPCAD stands for IP Cisco Accounting Daemon. It runs in background, listens traffic on the specified interfaces, and records the traffic for later retrieval and analysis. IPCAD can use raw BPF devices, PCAP library, divert, tee or Linux iptables' ULOG & IPQ packet sources to capture the packets.