aboutsummaryrefslogtreecommitdiffstats
path: root/package/ifxos/patches
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-03-31 17:24:43 +0000
committerJohn Crispin <blogic@openwrt.org>2010-03-31 17:24:43 +0000
commit56c8b05d3aeb1a76f21208551fc6a36ed0e46b1c (patch)
tree4bf28f3ec51671ab76502ad934944ad28b514c6e /package/ifxos/patches
parent5c331607b9f1c8413330d17b278457c43cda6186 (diff)
downloadupstream-56c8b05d3aeb1a76f21208551fc6a36ed0e46b1c.tar.gz
upstream-56c8b05d3aeb1a76f21208551fc6a36ed0e46b1c.tar.bz2
upstream-56c8b05d3aeb1a76f21208551fc6a36ed0e46b1c.zip
[ifxmips] update os abstraction layer
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20639 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ifxos/patches')
-rw-r--r--package/ifxos/patches/100-portability.patch27
1 files changed, 6 insertions, 21 deletions
diff --git a/package/ifxos/patches/100-portability.patch b/package/ifxos/patches/100-portability.patch
index 92b0ea01cc..51d6bbd165 100644
--- a/package/ifxos/patches/100-portability.patch
+++ b/package/ifxos/patches/100-portability.patch
@@ -1,23 +1,8 @@
---- a/configure.in
-+++ b/configure.in
-@@ -149,12 +149,12 @@ AC_ARG_ENABLE(targetincl,
- echo Set the target image include path $enableval
- AC_SUBST([TARGET_INCL_PATH],[$enableval])
- else
-- echo -e Set the default target image include path $DEFAULT_TARGET_INCL_PATH
-+ echo Set the default target image include path $DEFAULT_TARGET_INCL_PATH
- AC_SUBST([TARGET_INCL_PATH],[$DEFAULT_TARGET_INCL_PATH])
- fi
- ],
- [
-- echo -e Set the default target image include path $DEFAULT_TARGET_INCL_PATH
-+ echo Set the default target image include path $DEFAULT_TARGET_INCL_PATH
- AC_SUBST([TARGET_INCL_PATH],[$DEFAULT_TARGET_INCL_PATH])
- ]
- )
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -610,7 +610,7 @@ if KERNEL_2_6
+Index: lib_ifxos-1.5.12/src/Makefile.am
+===================================================================
+--- lib_ifxos-1.5.12.orig/src/Makefile.am 2010-01-08 18:12:15.000000000 +0100
++++ lib_ifxos-1.5.12/src/Makefile.am 2010-03-31 18:56:12.000000000 +0200
+@@ -639,7 +639,7 @@
drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
drv_ifxos.ko: $(drv_ifxos_SOURCES)
@@ -26,7 +11,7 @@
if test ! -e common/ifxos_debug.c ; then \
echo "copy source files (as links only!)"; \
for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
-@@ -618,10 +618,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
+@@ -647,10 +647,10 @@
cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
done \
fi