aboutsummaryrefslogtreecommitdiffstats
path: root/package/ifxmips-dsl-api/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-28 21:41:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-28 21:41:29 +0000
commit64a9519d9915580bcbd6791bddd28689cdb71d0c (patch)
tree65343ba54bf9adc57ee6eeb18fdb6d6d15d64592 /package/ifxmips-dsl-api/Makefile
parent5e7275d8237a359114e068be6a19f3b169d3b89b (diff)
downloadupstream-64a9519d9915580bcbd6791bddd28689cdb71d0c.tar.gz
upstream-64a9519d9915580bcbd6791bddd28689cdb71d0c.tar.bz2
upstream-64a9519d9915580bcbd6791bddd28689cdb71d0c.zip
ifxmips-dsl-api: fix portability errors
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20554 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ifxmips-dsl-api/Makefile')
-rw-r--r--package/ifxmips-dsl-api/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/ifxmips-dsl-api/Makefile b/package/ifxmips-dsl-api/Makefile
index fdb07214b1..3fc31eda43 100644
--- a/package/ifxmips-dsl-api/Makefile
+++ b/package/ifxmips-dsl-api/Makefile
@@ -117,6 +117,11 @@ define Build/Prepare
$(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(FW_BASE_NAME)_b-$(FW_B_VER).tar.gz
endef
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
+ $(call Build/Configure/Default)
+endef
+
define Build/Compile
cd $(LINUX_DIR); \
ARCH=mips CROSS_COMPILE="$(KERNEL_CROSS)" \