aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>2011-02-01 16:37:53 +0000
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>2011-02-01 16:37:53 +0000
commit824331a5943c0acfbb7b1fc95116c77092660f1e (patch)
tree46afa59e1229d17ea071ec170b4ca5a66ac44679 /package/hotplug2
parentbe8e23827ad7fb375bf4cd74c6e4eda994ab93f0 (diff)
downloadupstream-824331a5943c0acfbb7b1fc95116c77092660f1e.tar.gz
upstream-824331a5943c0acfbb7b1fc95116c77092660f1e.tar.bz2
upstream-824331a5943c0acfbb7b1fc95116c77092660f1e.zip
hotplug2: Use stricter matching for rule regular expressions
SVN-Revision: 25282
Diffstat (limited to 'package/hotplug2')
-rw-r--r--package/hotplug2/Makefile4
-rw-r--r--package/hotplug2/files/hotplug2.rules6
2 files changed, 5 insertions, 5 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index a4ff850ad9..de46332500 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hotplug2
PKG_REV:=201
PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV)
diff --git a/package/hotplug2/files/hotplug2.rules b/package/hotplug2/files/hotplug2.rules
index 9800658983..a7a4730105 100644
--- a/package/hotplug2/files/hotplug2.rules
+++ b/package/hotplug2/files/hotplug2.rules
@@ -1,10 +1,10 @@
$include /etc/hotplug2-common.rules
-SUBSYSTEM ~~ (net|input|button|usb|platform|ieee1394|block|atm) {
+SUBSYSTEM ~~ (^net$|^input$|^button$|^usb$|^platform$|^ieee1394$|^block$|^atm$) {
exec /sbin/hotplug-call %SUBSYSTEM%
}
-DEVICENAME ~~ (watchdog) {
+DEVICENAME == watchdog {
exec /sbin/watchdog -t 5 /dev/watchdog
- next
+ next-event
}