aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2011-02-01 16:37:53 +0000
committerVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2011-02-01 16:37:53 +0000
commit202a7b3712fc195a0d1795a4fe401b0fded7bc77 (patch)
treec3a7a893effe6ccfbb640d09e6a27d18c8d307a4 /package/hotplug2
parentbc043c24b1065d977160256a34a7f0f3cf03c65d (diff)
downloadupstream-202a7b3712fc195a0d1795a4fe401b0fded7bc77.tar.gz
upstream-202a7b3712fc195a0d1795a4fe401b0fded7bc77.tar.bz2
upstream-202a7b3712fc195a0d1795a4fe401b0fded7bc77.zip
[package] hotplug2: Use stricter matching for rule regular expressions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25282 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hotplug2')
-rw-r--r--package/hotplug2/Makefile4
-rw-r--r--package/hotplug2/files/hotplug2.rules6
2 files changed, 5 insertions, 5 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index a4ff850ad9..de46332500 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hotplug2
PKG_REV:=201
PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV)
diff --git a/package/hotplug2/files/hotplug2.rules b/package/hotplug2/files/hotplug2.rules
index 9800658983..a7a4730105 100644
--- a/package/hotplug2/files/hotplug2.rules
+++ b/package/hotplug2/files/hotplug2.rules
@@ -1,10 +1,10 @@
$include /etc/hotplug2-common.rules
-SUBSYSTEM ~~ (net|input|button|usb|platform|ieee1394|block|atm) {
+SUBSYSTEM ~~ (^net$|^input$|^button$|^usb$|^platform$|^ieee1394$|^block$|^atm$) {
exec /sbin/hotplug-call %SUBSYSTEM%
}
-DEVICENAME ~~ (watchdog) {
+DEVICENAME == watchdog {
exec /sbin/watchdog -t 5 /dev/watchdog
- next
+ next-event
}