aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-25 06:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-25 06:30:36 +0000
commitf0f5892884903cf45b2fe3c63a98fb75d50674ac (patch)
tree0dd9dbfb32b0c8a5ec66611105113c17e536bde9 /package/hotplug2
parent240a284e581023e970a4aeab5d62abc6095a7631 (diff)
downloadupstream-f0f5892884903cf45b2fe3c63a98fb75d50674ac.tar.gz
upstream-f0f5892884903cf45b2fe3c63a98fb75d50674ac.tar.bz2
upstream-f0f5892884903cf45b2fe3c63a98fb75d50674ac.zip
make hotplug2 use the build system cflags
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7720 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hotplug2')
-rw-r--r--package/hotplug2/Makefile1
-rw-r--r--package/hotplug2/patches/110-depend_fix.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 6b69bac733..bf7c8c6b09 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -29,6 +29,7 @@ define Package/hotplug2/description
Hotplug2 is a trivial replacement of some of the UDev functionality
in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
endef
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
define Package/hotplug2/install
$(INSTALL_DIR) $(1)/etc
diff --git a/package/hotplug2/patches/110-depend_fix.patch b/package/hotplug2/patches/110-depend_fix.patch
new file mode 100644
index 0000000000..762b26fa18
--- /dev/null
+++ b/package/hotplug2/patches/110-depend_fix.patch
@@ -0,0 +1,13 @@
+Index: hotplug2-0.9/common.mak
+===================================================================
+--- hotplug2-0.9.orig/common.mak 2007-06-25 08:08:59.320226312 +0200
++++ hotplug2-0.9/common.mak 2007-06-25 08:09:03.541584568 +0200
+@@ -10,7 +10,7 @@
+ .PHONY: all clean dep install install-recursive clean-recursive \
+ dep-recursive all-recursive
+
+-MAKEDEP=-gcc $(CFLAGS) -MM $(wildcard *.c *.cc) > .depend
++MAKEDEP=-$(CC) $(CFLAGS) -MM $(wildcard *.c *.cc) > .depend
+ dep: dep-recursive
+ $(MAKEDEP)
+ .depend: