aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 20:49:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 20:49:44 +0000
commitebb11510328149a2da6b635b1aba3bd38f3e7652 (patch)
tree121f142cd0f9173667d394e49c8864159076a187 /package/hotplug2/Makefile
parent28e212cc4050e3acf2266efb8092ec8f4c33da67 (diff)
downloadupstream-ebb11510328149a2da6b635b1aba3bd38f3e7652.tar.gz
upstream-ebb11510328149a2da6b635b1aba3bd38f3e7652.tar.bz2
upstream-ebb11510328149a2da6b635b1aba3bd38f3e7652.zip
hotplug2: compile in the worker module statically, saves >20k uncompressed
SVN-Revision: 18104
Diffstat (limited to 'package/hotplug2/Makefile')
-rw-r--r--package/hotplug2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 3dab96ba7f..b51e5a97f6 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -36,15 +36,15 @@ define Package/hotplug2/description
This is an implementation of Hotplug2-1.0-beta
endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) $(FPIC) -DHAVE_RULES -I."
+MAKE_FLAGS += \
+ COPTS="$(TARGET_CFLAGS)" \
+ STATIC_WORKER="fork"
define Package/hotplug2/install
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
- $(INSTALL_DIR) $(1)/lib/hotplug2
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/workers/worker_fork.so $(1)/lib/hotplug2
endef
$(eval $(call BuildPackage,hotplug2))