aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-13 13:16:11 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-13 13:16:11 +0000
commit87ba485e6d4d1399ed493e78632b3c4095c2dba3 (patch)
tree930e1103540870ec9ca3f76af815b6c3f5843b72 /package/hotplug2/Makefile
parent877522621ea595841f32adc367322b4305465966 (diff)
downloadupstream-87ba485e6d4d1399ed493e78632b3c4095c2dba3.tar.gz
upstream-87ba485e6d4d1399ed493e78632b3c4095c2dba3.tar.bz2
upstream-87ba485e6d4d1399ed493e78632b3c4095c2dba3.zip
[package/hotplug] link hotplug2 against libbsd when eglibc is used
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27170 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hotplug2/Makefile')
-rw-r--r--package/hotplug2/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 7e1dda7a04..9625ba27f9 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -28,6 +28,7 @@ define Package/hotplug2
VERSION:=1.0-beta-$(PKG_RELEASE)
TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+ DEPENDS:=+USE_EGLIBC:libbsd
endef
define Package/hotplug2/description
@@ -44,9 +45,13 @@ MAKE_FLAGS += \
COPTS="$(TARGET_CFLAGS)" \
STATIC_WORKER="fork"
+ifneq ($(CONFIG_USE_EGLIBC),)
+ TARGET_LDFLAGS += -lbsd
+endif
+
define Build/Compile
$(call Build/Compile/Default)
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
endef
define Package/hotplug2/install