aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-24 00:08:08 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-24 00:08:08 +0000
commit21d7852de0baa1bb6b466a887d227e243df593ee (patch)
tree3f7b5cda53614c4d991f4cadfc607c18dfcf02d1 /package/hostapd
parente80fb36f396323d88d8bdf192d93dceeb6be2dbd (diff)
downloadupstream-21d7852de0baa1bb6b466a887d227e243df593ee.tar.gz
upstream-21d7852de0baa1bb6b466a887d227e243df593ee.tar.bz2
upstream-21d7852de0baa1bb6b466a887d227e243df593ee.zip
replace some -I & -L flags with $(TARGET_CPPFLAGS) & $(TARGET_LDFLAGS) when appropriate
SVN-Revision: 14651
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index a0da7a7e93..e4f3655473 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -94,11 +94,11 @@ define Build/ConfigureTarget
endef
define Build/CompileTarget
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/madwifi -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl -I$(STAGING_DIR)/usr/include" \
+ CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/madwifi -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl $(TARGET_CPPFLAGS)" \
$(MAKE) -C $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd \
$(TARGET_CONFIGURE_OPTS) \
$(DRIVER_MAKEOPTS) \
- LIBS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib \
+ LIBS="$(TARGET_LDFLAGS) \
$(if $(CONFIG_PACKAGE_kmod-mac80211),-lm $(STAGING_DIR)/usr/lib/libnl.a) \
$(if $(findstring default,$(1)),-lssl -lcrypto)" \
hostapd hostapd_cli