aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-27 15:53:00 +0000
commit7658ef1316a0ddd0683583ca1a5978b1da4d6917 (patch)
treeb3d4b16923c5612599607d55a521d09b723cdcc9 /package/hostapd
parent9f627dbf6e018c2c61ea3254b4ab9d80ae70c213 (diff)
downloadupstream-7658ef1316a0ddd0683583ca1a5978b1da4d6917.tar.gz
upstream-7658ef1316a0ddd0683583ca1a5978b1da4d6917.tar.bz2
upstream-7658ef1316a0ddd0683583ca1a5978b1da4d6917.zip
introduce a generic PKG_CONFIG_DEPENDS for packages that need to be reconfigured when certain CONFIG options changed, rename PKG_BUILD_DEPEND to PKG_BUILD_DEPENDS
SVN-Revision: 15451
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 4955979309..0c1d6fc776 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -16,18 +16,20 @@ PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_MD5SUM:=83630d11fa66ade9091f1b304fccd74c
-PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi PACKAGE_kmod-mac80211:mac80211 PACKAGE_kmod-mac80211:libnl
-include $(INCLUDE_DIR)/package.mk
+PKG_BUILD_DEPENDS:= \
+ PACKAGE_kmod-madwifi:madwifi \
+ PACKAGE_kmod-mac80211:mac80211 \
+ PACKAGE_kmod-mac80211:libnl \
-PKG_CONFDEPS := \
+PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-ath9k \
CONFIG_PACKAGE_kmod-mac80211 \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
- CONFIG_PACKAGE_hostapd-mini
+ CONFIG_PACKAGE_hostapd-mini \
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,$(PKG_CONFDEPS))
+include $(INCLUDE_DIR)/package.mk
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \