aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-24 20:54:13 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-24 20:54:13 +0000
commita886b7ad0db1f1f8ff3a3323a2d79f28fe945342 (patch)
tree247ee7b166c3f6941e97b8358b04083ec99ac2dc /package/hostapd
parentcb51e6c0d77decd543da17689afcb3abfb68aa60 (diff)
downloadupstream-a886b7ad0db1f1f8ff3a3323a2d79f28fe945342.tar.gz
upstream-a886b7ad0db1f1f8ff3a3323a2d79f28fe945342.tar.bz2
upstream-a886b7ad0db1f1f8ff3a3323a2d79f28fe945342.zip
[package] hostapd: introduce a client_cert option which is passed on to wpa_supplicant (#8876)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29901 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile4
-rw-r--r--package/hostapd/files/wpa_supplicant.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 3b6b6feb3e..c4e5d9f25a 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
PKG_VERSION:=20111103
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_REV:=6caaae1e48da247b21b54ea6001646597e35d9b1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/hostapd/files/wpa_supplicant.sh b/package/hostapd/files/wpa_supplicant.sh
index 1ab6c663e5..9446202be3 100644
--- a/package/hostapd/files/wpa_supplicant.sh
+++ b/package/hostapd/files/wpa_supplicant.sh
@@ -87,9 +87,11 @@ wpa_supplicant_setup_vif() {
pairwise='pairwise=CCMP'
group='group=CCMP'
config_get identity "$vif" identity
+ config_get client_cert "$vif" client_cert
config_get priv_key "$vif" priv_key
config_get priv_key_pwd "$vif" priv_key_pwd
identity="identity=\"$identity\""
+ client_cert="client_cert=\"$client_cert\""
priv_key="private_key=\"$priv_key\""
priv_key_pwd="private_key_passwd=\"$priv_key_pwd\""
;;
@@ -132,6 +134,7 @@ network={
$group
$eap_type
$ca_cert
+ $client_cert
$priv_key
$priv_key_pwd
$phase2