aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/patches
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-02-16 18:51:55 +0000
committerMichael Büsch <mb@bu3sch.de>2008-02-16 18:51:55 +0000
commit38a03804d4cfe1d2bc642cb9686095d8144a1967 (patch)
treebec57e7b12848bad64b391615efe828f442f24bc /package/hostapd/patches
parentfa657fadc0aff63b8ae1d5f0e640716a8144ad8d (diff)
downloadupstream-38a03804d4cfe1d2bc642cb9686095d8144a1967.tar.gz
upstream-38a03804d4cfe1d2bc642cb9686095d8144a1967.tar.bz2
upstream-38a03804d4cfe1d2bc642cb9686095d8144a1967.zip
Add hostapd support for nl80211 (mac80211 stack)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10469 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/patches')
-rw-r--r--package/hostapd/patches/007-add-nl80211-driver.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/hostapd/patches/007-add-nl80211-driver.patch b/package/hostapd/patches/007-add-nl80211-driver.patch
new file mode 100644
index 0000000000..538890c3ed
--- /dev/null
+++ b/package/hostapd/patches/007-add-nl80211-driver.patch
@@ -0,0 +1,17 @@
+Index: hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/Makefile
+===================================================================
+--- hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576.orig/hostapd/Makefile 2007-11-16 05:08:24.000000000 +0100
++++ hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/Makefile 2008-02-16 19:38:51.000000000 +0100
+@@ -121,6 +121,12 @@ OBJS += driver_devicescape.o
+ LIBS += -lnl
+ endif
+
++ifdef CONFIG_DRIVER_NL80211
++CFLAGS += -DCONFIG_DRIVER_NL80211
++OBJS += driver_nl80211.o radiotap.o
++LIBS += -lnl
++endif
++
+ ifdef CONFIG_DRIVER_BSD
+ CFLAGS += -DCONFIG_DRIVER_BSD
+ OBJS += driver_bsd.o