aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:22 +0000
commit1d45111aa57e1007321d15ac9ffe949e1a4341d7 (patch)
tree19d3eb291976d80afdd846e965be140d9ffc8a87 /package/hostapd/Makefile
parentca4a8b1bee22646319f8e2aeb1ed59062403a9b8 (diff)
downloadupstream-1d45111aa57e1007321d15ac9ffe949e1a4341d7.tar.gz
upstream-1d45111aa57e1007321d15ac9ffe949e1a4341d7.tar.bz2
upstream-1d45111aa57e1007321d15ac9ffe949e1a4341d7.zip
hostapd: make rfkill support optional
SVN-Revision: 22101
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index dcbe9e53a6..3e4864dcc0 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -30,7 +30,8 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
CONFIG_PACKAGE_hostapd-mini \
- CONFIG_PACKAGE_kmod-hostap
+ CONFIG_PACKAGE_kmod-hostap \
+ CONFIG_WPA_RFKILL_SUPPORT
LOCAL_TYPE=$(strip \
$(if $(findstring wpad,$(BUILD_VARIANT)),wpad, \
@@ -64,7 +65,8 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
- CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+ CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
+ $(if $(CONFIG_WPA_RFKILL_SUPPORT),NEED_RFKILL=y)
ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_OPENSSL