aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 23:37:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 23:37:24 +0000
commitbf37cfa0f765b573d07217288f2023ef57bb963f (patch)
treeba70e3b627e4e61b252e595a05ecc4de9e45b99d /package/hostapd/Makefile
parent9a6dacf9aea73439483e9d134a9bd3621275a2ec (diff)
downloadupstream-bf37cfa0f765b573d07217288f2023ef57bb963f.tar.gz
upstream-bf37cfa0f765b573d07217288f2023ef57bb963f.tar.bz2
upstream-bf37cfa0f765b573d07217288f2023ef57bb963f.zip
fix hostapd build with openssl
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9574 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 8cdbd7750a..af215f6fff 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_BUILD_DEPENDS:=madwifi mac80211 libnl
+PKG_BUILD_DEPENDS:=madwifi mac80211 libnl openssl
include $(INCLUDE_DIR)/package.mk
$(eval $(call confvar,STAMP_CONFIGURED,CONFIG_PACKAGE_kmod-mac80211 CONFIG_PACKAGE_kmod-madwifi))
@@ -83,7 +83,8 @@ define Build/CompileTarget
$(MAKE) -C $(PKG_BUILD_DIR)/hostapd.$(1) \
$(TARGET_CONFIGURE_OPTS) \
LIBS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib \
- $(if $(CONFIG_PACKAGE_kmod-mac80211),-lm $(STAGING_DIR)/usr/lib/libnl.a)" \
+ $(if $(CONFIG_PACKAGE_kmod-mac80211),-lm $(STAGING_DIR)/usr/lib/libnl.a) \
+ $(if $(findstring default,$(1)),-lssl -lcrypto)" \
hostapd hostapd_cli
$(CP) $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd_cli $(PKG_BUILD_DIR)/
endef