aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-01-23 18:25:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-01-23 18:25:04 +0000
commit890c1bdcbe3240e249fded843f07869224fb2e84 (patch)
tree1ce76ff0326ae7585021c29e886bec3bf50a334f /package/hostapd/Makefile
parent3624a3e646fb8b4f9cf0066037fb74379f47bf40 (diff)
downloadupstream-890c1bdcbe3240e249fded843f07869224fb2e84.tar.gz
upstream-890c1bdcbe3240e249fded843f07869224fb2e84.tar.bz2
upstream-890c1bdcbe3240e249fded843f07869224fb2e84.zip
hostapd: fix wpad compile error by preventing make spam from showing up in the cflags/ldflags dump files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19295 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 93392110ab..3aec903728 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -218,8 +218,8 @@ endef
define Build/Compile/wpad
echo ` \
- $(call Build/RunMake,hostapd,MULTICALL=1 dump_cflags); \
- $(call Build/RunMake,wpa_supplicant,dump_cflags) | sed -e 's,$(TARGET_CFLAGS),,' \
+ $(call Build/RunMake,hostapd,-s MULTICALL=1 dump_cflags); \
+ $(call Build/RunMake,wpa_supplicant,-s dump_cflags) | sed -e 's,$(TARGET_CFLAGS),,' \
` > $(PKG_BUILD_DIR)/.cflags
$(call Build/RunMake,hostapd, \
CFLAGS="$$$$(cat $(PKG_BUILD_DIR)/.cflags)" \