aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:22 +0000
commit7c5114a298cfeb6670c03b3bf17b9cac5bbeb277 (patch)
tree8bb224188341a0d3059f23c3bfb49ecc66f8ddb3 /package/hostapd/Makefile
parentb94a8c0025bb2d5983ba2ad1d61137f271120e80 (diff)
downloadupstream-7c5114a298cfeb6670c03b3bf17b9cac5bbeb277.tar.gz
upstream-7c5114a298cfeb6670c03b3bf17b9cac5bbeb277.tar.bz2
upstream-7c5114a298cfeb6670c03b3bf17b9cac5bbeb277.zip
hostapd: make rfkill support optional
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22101 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index dcbe9e53a6..3e4864dcc0 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -30,7 +30,8 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
CONFIG_PACKAGE_hostapd-mini \
- CONFIG_PACKAGE_kmod-hostap
+ CONFIG_PACKAGE_kmod-hostap \
+ CONFIG_WPA_RFKILL_SUPPORT
LOCAL_TYPE=$(strip \
$(if $(findstring wpad,$(BUILD_VARIANT)),wpad, \
@@ -64,7 +65,8 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
- CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+ CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
+ $(if $(CONFIG_WPA_RFKILL_SUPPORT),NEED_RFKILL=y)
ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_OPENSSL