aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-31 15:34:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-31 15:34:51 +0000
commit5c331607b9f1c8413330d17b278457c43cda6186 (patch)
treea3bfc8f2a28b7947a8e30b5601ecfb4ca2fe1351 /package/hostapd/Makefile
parente0259bb9116d33a46f90b3edf9174834635a1ec6 (diff)
downloadupstream-5c331607b9f1c8413330d17b278457c43cda6186.tar.gz
upstream-5c331607b9f1c8413330d17b278457c43cda6186.tar.bz2
upstream-5c331607b9f1c8413330d17b278457c43cda6186.zip
hostapd: fix build error caused by r20631
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20638 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 38d91875eb..0ccba9ad99 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -25,6 +25,7 @@ PKG_BUILD_DEPENDS:= \
PKG_CONFIG_DEPENDS:= \
CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
CONFIG_PACKAGE_kmod-ath9k \
+ CONFIG_PACKAGE_kmod-rt2800-lib \
CONFIG_PACKAGE_kmod-mac80211 \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
@@ -50,11 +51,19 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
include $(INCLUDE_DIR)/package.mk
+ifneq ($(CONFIG_PACKAGE_kmod-rt2800-lib),)
+ HOSTAPD_IEEE80211N:=y
+endif
+
+ifneq ($(CONFIG_PACKAGE_kmod-ath9k),)
+ HOSTAPD_IEEE80211N:=y
+endif
+
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
- CONFIG_IEEE80211N=$(if ($(CONFIG_PACKAGE_kmod-ath9k)$(CONFIG_PACKAGE_kmod-rt2800-lib)),y) \
+ CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
ifneq ($(LOCAL_TYPE),hostapd)