aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 21:14:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 21:14:57 +0000
commit53c6087f48dd2bf05f51548c2a51eab77a2763f8 (patch)
tree528a6a4e5219f5d466e380d4d447c87a2191d0c5 /package/hostapd/Makefile
parent3c635449d3bea9a2042b3e9a21586a98122b7eca (diff)
downloadupstream-53c6087f48dd2bf05f51548c2a51eab77a2763f8.tar.gz
upstream-53c6087f48dd2bf05f51548c2a51eab77a2763f8.tar.bz2
upstream-53c6087f48dd2bf05f51548c2a51eab77a2763f8.zip
hostapd: make compilation of the hostap driver conditional - saves 10k uncompressed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18107 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 55bef9bfdd..ddf21683bd 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -27,12 +27,14 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
CONFIG_PACKAGE_hostapd-mini \
+ CONFIG_PACKAGE_kmod-hostap
include $(INCLUDE_DIR)/package.mk
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
+ CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
define Package/hostapd/Default