aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-02 12:01:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-02 12:01:08 +0000
commit25791aaf8d752872b7fc106fc9b183e8f2f75b13 (patch)
tree1867d3ab809bdcd05136a19aae4cc70c533c26ff /package/hostapd/Makefile
parent8f5b76c8d3e1fa920e1e4eb4589f7b32b9f65ad9 (diff)
downloadupstream-25791aaf8d752872b7fc106fc9b183e8f2f75b13.tar.gz
upstream-25791aaf8d752872b7fc106fc9b183e8f2f75b13.tar.bz2
upstream-25791aaf8d752872b7fc106fc9b183e8f2f75b13.zip
hostapd: use -ffunction-sections, -fdata-sections and --gc-sections, reduces binary size a bit
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25821 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 3b4978fc86..83622b41ba 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -225,6 +225,9 @@ TARGET_CPPFLAGS := \
-DCONFIG_LIBNL20 \
-D_GNU_SOURCE
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny
endif