aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostap-utils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/hostap-utils
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadupstream-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
upstream-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
upstream-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/hostap-utils')
-rw-r--r--package/hostap-utils/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/hostap-utils/Makefile b/package/hostap-utils/Makefile
index 68afdd2709..4f4be05890 100644
--- a/package/hostap-utils/Makefile
+++ b/package/hostap-utils/Makefile
@@ -36,13 +36,13 @@ define Build/Compile
endef
define Package/hostap-utils/install
- install -m0755 -d $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/hostap_crypt_conf $(1)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/hostap_diag $(1)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/hostap_io_debug $(1)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/hostap_rid $(1)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/prism2_srec $(1)/usr/sbin/
- install -m0755 $(PKG_BUILD_DIR)/split_combined_hex $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_crypt_conf $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_diag $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_io_debug $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_rid $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/prism2_srec $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/split_combined_hex $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,hostap-utils))