aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostap-driver
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-16 16:21:56 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-16 16:21:56 +0000
commitfc0f5aa51714bd096d12afc15d30cf3c37e40124 (patch)
tree5de56b655c609b970c0b21e3d5d41f8cbaa8b693 /package/hostap-driver
parent53043787d3bf331565779dd1d81c64a460058940 (diff)
downloadupstream-fc0f5aa51714bd096d12afc15d30cf3c37e40124.tar.gz
upstream-fc0f5aa51714bd096d12afc15d30cf3c37e40124.tar.bz2
upstream-fc0f5aa51714bd096d12afc15d30cf3c37e40124.zip
add missing dependencies on PCI/PCMCIA/USB support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostap-driver')
-rw-r--r--package/hostap-driver/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hostap-driver/Makefile b/package/hostap-driver/Makefile
index 9ade13ec65..b784131a1d 100644
--- a/package/hostap-driver/Makefile
+++ b/package/hostap-driver/Makefile
@@ -70,7 +70,7 @@ endef
define KernelPackage/hostap-pci
$(call KernelPackage/hostap/Default)
- DEPENDS:=kmod-hostap
+ DEPENDS:=@PCI_SUPPORT kmod-hostap
TITLE:=Host AP driver for PCI adaptors
KCONFIG:=CONFIG_HOSTAP_PCI
AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
@@ -91,7 +91,7 @@ endef
define KernelPackage/hostap-plx
$(call KernelPackage/hostap/Default)
- DEPENDS:=kmod-hostap
+ DEPENDS:=@PCI_SUPPORT kmod-hostap
KCONFIG:=CONFIG_HOSTAP_PLX
TITLE:=Host AP driver for PLX9052 based PCI adaptors
AUTOLOAD:=$(call AutoLoad,60,hostap_plx)