aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-09-30 14:48:31 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-09-30 14:48:31 +0000
commitcd3128399ace3a1dac9a2a77ba325d7f70a377df (patch)
treedd94e5959a79eae1933f3481e3d87da9afbea617 /package/grub
parent3b225c10322abd6545da9b406a3fc920c329f2b7 (diff)
downloadupstream-cd3128399ace3a1dac9a2a77ba325d7f70a377df.tar.gz
upstream-cd3128399ace3a1dac9a2a77ba325d7f70a377df.tar.bz2
upstream-cd3128399ace3a1dac9a2a77ba325d7f70a377df.zip
package/grub: fix build issues under 64bit FreeBSD
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index f3dd171141..ee527be13f 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -37,10 +37,6 @@ MY_CONFIGURE_ARGS += \
--disable-hercules \
--without-curses \
-ifeq ($(HOST_OS),FreeBSD)
- MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
-endif
-
MY_CONFIGURE_VARS += \
grub_cv_prog_objcopy_absolute=yes \
@@ -53,6 +49,14 @@ ifeq ($(HOST_OS),Darwin)
HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
endif
+ifeq ($(HOST_OS),FreeBSD)
+ ifeq ($(HOST_ARCH),amd64)
+ HOST_CFLAGS += $(call host-cc-option,-m32)
+ HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
+ HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)
+ endif
+endif
+
HOST_CFLAGS += $(call host-cc-option,-fno-stack-protector)
HOST_CFLAGS += $(call host-cc-option,-U_FORTIFY_SOURCE)