aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-07 21:23:09 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-07 21:23:09 +0000
commitcac4162fa05dc96f4ee66aac105548f55c5f41e7 (patch)
tree1f29b0cc1942a4038024fb71944d6563cfc57ccd /package/grub
parent8abc88276428afd28c5f73d2119256d7f7022828 (diff)
downloadupstream-cac4162fa05dc96f4ee66aac105548f55c5f41e7.tar.gz
upstream-cac4162fa05dc96f4ee66aac105548f55c5f41e7.tar.bz2
upstream-cac4162fa05dc96f4ee66aac105548f55c5f41e7.zip
package/grub: play it safe, cross compile everywhere
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 94695ec970..338dbcac1d 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -31,20 +31,10 @@ define Package/grub
URL:=http://www.gnu.org/software/grub/
endef
-ifeq ($(HOST_OS),Linux)
- NATIVEGRUB-i386:=1
- NATIVEGRUB-i686:=1
- NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
-endif
-
-ifeq ($(NATIVEGRUB),)
CONFIGURE_FLAGS:= \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME)
-else
-CONFIGURE_FLAGS:=
-endif
ifneq ($(HOST_OS),Darwin)
define Build/Configure