aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-08-16 09:12:46 +0000
committerNicolas Thill <nico@openwrt.org>2010-08-16 09:12:46 +0000
commit820b2168d52b92f8d9dcc46591ee9260f63c8163 (patch)
tree67448ad100ff47d79f9850f9350e39716b529a5c /package/grub
parent00373aa7b84dd4bb2710a68bcf7750f48bb2c827 (diff)
downloadupstream-820b2168d52b92f8d9dcc46591ee9260f63c8163.tar.gz
upstream-820b2168d52b92f8d9dcc46591ee9260f63c8163.tar.bz2
upstream-820b2168d52b92f8d9dcc46591ee9260f63c8163.zip
package/grub: add a prereq check for 32 bits host development files when building on x86_64 (closes: #7753)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22667 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 5fd2a23088..426b9c3673 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -88,5 +88,16 @@ define Package/grub/install
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
endef
+ifeq ($(HOST_ARCH),x86_64)
+ define Require/working-gcc-m32
+ echo 'int main(int argc, char **argv) { return 0; }' | \
+ gcc -x c -o $(TMP_DIR)/a.out - -m32 -lc
+ endef
+endif
+
+$(eval $(call Require,working-gcc-m32, \
+ Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL) \
+))
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,grub))