aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-05-04 23:08:08 +0000
committerNicolas Thill <nico@openwrt.org>2009-05-04 23:08:08 +0000
commit74f9a035ae5218c30a87fa6d3c8c9111745319f4 (patch)
tree523da9c22c6918eb4fb32986d782fe4115710cee /package/grub
parent8d222ed4793d0a34b2b43ac4f0afe64a37fb6d32 (diff)
downloadupstream-74f9a035ae5218c30a87fa6d3c8c9111745319f4.tar.gz
upstream-74f9a035ae5218c30a87fa6d3c8c9111745319f4.tar.bz2
upstream-74f9a035ae5218c30a87fa6d3c8c9111745319f4.zip
[package] grub: fix potential build issues on redhat/fedora host systems (should close: #3793)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15608 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile4
-rw-r--r--package/grub/patches/002-strip_note_gnu_build_id.patch22
2 files changed, 24 insertions, 2 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index e828ec0338..94695ec970 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=grub
PKG_VERSION:=0.97
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
diff --git a/package/grub/patches/002-strip_note_gnu_build_id.patch b/package/grub/patches/002-strip_note_gnu_build_id.patch
new file mode 100644
index 0000000000..40aa74dc79
--- /dev/null
+++ b/package/grub/patches/002-strip_note_gnu_build_id.patch
@@ -0,0 +1,22 @@
+--- a/stage1/Makefile.in
++++ b/stage1/Makefile.in
+@@ -427,7 +427,7 @@ uninstall-am: uninstall-info-am uninstal
+ uninstall-nodist_pkglibDATA
+
+ .exec:
+- $(OBJCOPY) -O binary $< $@
++ $(OBJCOPY) -O binary -R .comment -R .note -R .note.gnu.build-id $< $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
+--- a/stage2/Makefile.in
++++ b/stage2/Makefile.in
+@@ -3244,7 +3244,7 @@ pxegrub: pxeloader diskless
+ -rm -f $@
+ cat $^ > $@
+ .exec:
+- $(OBJCOPY) -O binary $< $@
++ $(OBJCOPY) -O binary -R .comment -R .note -R .note.gnu.build-id $< $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: