aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-30 07:07:20 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-30 07:07:20 +0000
commit60cfd441cc66692a0d8db712bd886307d2fda1ea (patch)
tree7cc9bf6a137581696aa6af8642acab7d2722cc3c /package/grub
parente7c7c17023225a115a7e7eddaacb5947854ea2fa (diff)
downloadupstream-60cfd441cc66692a0d8db712bd886307d2fda1ea.tar.gz
upstream-60cfd441cc66692a0d8db712bd886307d2fda1ea.tar.bz2
upstream-60cfd441cc66692a0d8db712bd886307d2fda1ea.zip
package/grub: fix x86_64 issue (closes #7248)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21264 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 9a50f820ec..20232f4954 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -36,9 +36,12 @@ CONFIGURE_FLAGS:=
ifneq ($(HOST_OS),Darwin)
define Build/Configure
(cd $(PKG_BUILD_DIR); \
+ CFLAGS="-march=i486 -m32" \
LDFLAGS="-static" \
./configure \
$(CONFIGURE_FLAGS) \
+ --build=i386-linux-gnu \
+ --host=i386-linux-gnu \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \