aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-28 17:54:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-28 17:54:44 +0000
commit3f198c6c0e1f8ed135b8b226c2e533f4a3494647 (patch)
treec2cda35393f954ec31b143f9727e588530ea7223 /package/grub
parent93a27d7477a7223f86587e1e1fa0cfdd1703c5e5 (diff)
downloadupstream-3f198c6c0e1f8ed135b8b226c2e533f4a3494647.tar.gz
upstream-3f198c6c0e1f8ed135b8b226c2e533f4a3494647.tar.bz2
upstream-3f198c6c0e1f8ed135b8b226c2e533f4a3494647.zip
x86: don't attempt to compile grub on darwin
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11599 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 7dfd1429d2..434af2bc9b 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -45,6 +45,7 @@ else
CONFIGURE_FLAGS:=
endif
+ifneq ($(HOST_OS),Darwin)
define Build/Configure
(cd $(PKG_BUILD_DIR); \
LDFLAGS="-static" \
@@ -83,5 +84,6 @@ define Build/InstallDev
install
mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
endef
+endif
$(eval $(call BuildPackage,grub))