aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-06-20 01:43:20 +0000
committerAndy Boyett <agb@openwrt.org>2008-06-20 01:43:20 +0000
commit38bedf1cfdcf7642b1d71a40e6d6b432c66c5a3c (patch)
tree96f81f84de21c55b9b5cde1f2b07a8b2f66228cd /package/grub
parent55e616c10b9cc918c91a54a78100ab42cbf57ee8 (diff)
downloadupstream-38bedf1cfdcf7642b1d71a40e6d6b432c66c5a3c.tar.gz
upstream-38bedf1cfdcf7642b1d71a40e6d6b432c66c5a3c.tar.bz2
upstream-38bedf1cfdcf7642b1d71a40e6d6b432c66c5a3c.zip
[x86] grub: Natively build grub only on x86 linux hosts, cross compile everywhere else.
- Closes #3560 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11542 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/grub')
-rw-r--r--package/grub/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 98bb68b564..7dfd1429d2 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -30,7 +30,13 @@ define Package/grub
URL:=http://www.gnu.org/software/grub/
endef
-ifeq ($(HOST_ARCH),x86_64)
+ifeq ($(HOST_OS),Linux)
+ NATIVEGRUB-i386:=1
+ NATIVEGRUB-i686:=1
+ NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
+endif
+
+ifeq ($(NATIVEGRUB),)
CONFIGURE_FLAGS:= \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -62,7 +68,7 @@ define Build/Configure
endef
#
-# ./configure detects whether the host compiler supports
+# ./configure detects whether the host compiler supports
# -fno-stack-protector but only sets STAGE2_CFLAGS accordingly
#
define Build/Compile