aboutsummaryrefslogtreecommitdiffstats
path: root/package/gnutls/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-18 08:18:15 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-18 08:18:15 +0000
commit3bfc66e823d1953dd96b224f5db97c8d9526290f (patch)
treece4450ec57f3e48009f0662a4fd20cf958ece86e /package/gnutls/Makefile
parentfd3eb12d45e86570aa5c06df7aae2b5d52b2cbd1 (diff)
downloadupstream-3bfc66e823d1953dd96b224f5db97c8d9526290f.tar.gz
upstream-3bfc66e823d1953dd96b224f5db97c8d9526290f.tar.bz2
upstream-3bfc66e823d1953dd96b224f5db97c8d9526290f.zip
do not depend on external opencdk (not used) and libtasn1, use bundled version instead,
set common lib searchpath git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1695 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/gnutls/Makefile')
-rw-r--r--package/gnutls/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/gnutls/Makefile b/package/gnutls/Makefile
index fdb3b13b0c..3e8a31ea99 100644
--- a/package/gnutls/Makefile
+++ b/package/gnutls/Makefile
@@ -35,7 +35,7 @@ $(PKG_BUILD_DIR)/.configured:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -62,10 +62,9 @@ $(PKG_BUILD_DIR)/.configured:
--disable-srp-authentication \
--disable-anon-authentication \
--disable-openpgp-authentication \
- --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
- --with-libopencdk-prefix="$(STAGING_DIR)/usr" \
- --with-libtasn1-prefix="$(STAGING_DIR)/usr" \
- --with-included-libcfg \
+ --with-included-opencdk=yes \
+ --with-included-libtasn1=yes \
+ --with-included-libcfg=yes \
--without-zlib \
--without-lzo \
);