aboutsummaryrefslogtreecommitdiffstats
path: root/package/gdb
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-20 23:24:16 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-20 23:24:16 +0000
commit71248f45c7284f4f788e0e4298ed3cacac72a564 (patch)
tree0eba3e3f3791ad40708fd57cc127e1d89a8b177c /package/gdb
parent49a0eaa0abf58c0111b74f85d3ef8487f283653e (diff)
downloadupstream-71248f45c7284f4f788e0e4298ed3cacac72a564.tar.gz
upstream-71248f45c7284f4f788e0e4298ed3cacac72a564.tar.bz2
upstream-71248f45c7284f4f788e0e4298ed3cacac72a564.zip
[package] gdb: fix build failure with arm targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18865 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/gdb')
-rw-r--r--package/gdb/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/gdb/Makefile b/package/gdb/Makefile
index d2bb43be95..4ecda6841c 100644
--- a/package/gdb/Makefile
+++ b/package/gdb/Makefile
@@ -42,8 +42,10 @@ define Package/gdbserver/description
than the one which is running the program being debugged.
endef
+# XXX: add --disable-werror to prevent build failure with arm
CONFIGURE_ARGS+= \
- --with-system-readline
+ --with-system-readline \
+ --disable-werror \
CONFIGURE_VARS+= \
ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"