aboutsummaryrefslogtreecommitdiffstats
path: root/package/fuse/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-12-15 16:06:45 +0000
committerNicolas Thill <nico@openwrt.org>2006-12-15 16:06:45 +0000
commitf55acbecec44d686db833b69b8eedf78c08790e7 (patch)
tree599b22dd208792c8d760bc21fe68f77cf6ac35e7 /package/fuse/patches
parent3836d35a2643bcec8c3674a57de7f531e19a9e2e (diff)
downloadupstream-f55acbecec44d686db833b69b8eedf78c08790e7.tar.gz
upstream-f55acbecec44d686db833b69b8eedf78c08790e7.tar.bz2
upstream-f55acbecec44d686db833b69b8eedf78c08790e7.zip
update fuse to 2.6.1 (fix build on 2.6.19), remove kmod_build patch needed for 2.4 and make fuse 2.6 only
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5799 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/fuse/patches')
-rw-r--r--package/fuse/patches/101-kmod_build.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/package/fuse/patches/101-kmod_build.patch b/package/fuse/patches/101-kmod_build.patch
index e541d47142..e69de29bb2 100644
--- a/package/fuse/patches/101-kmod_build.patch
+++ b/package/fuse/patches/101-kmod_build.patch
@@ -1,46 +0,0 @@
-diff -Nur fuse-2.5.2/kernel/Makefile.in fuse-2.5.2.patched/kernel/Makefile.in
---- fuse-2.5.2/kernel/Makefile.in 2006-02-02 18:04:52.000000000 +0100
-+++ fuse-2.5.2.patched/kernel/Makefile.in 2006-03-28 20:17:13.000000000 +0200
-@@ -54,23 +54,8 @@
-
- ifeq ($(majver), 2.4)
-
--CC = gcc
--LD = ld
--CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe @KERNELCFLAGS@
--CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
--
- fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
-
--SUFFIXES = .c .o .s
--
--all-spec: fuse.o
--
--.c.o:
-- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
--
--fuse.o: $(fuse_objs)
-- $(LD) -r -o fuse.o $(fuse_objs)
--
- fuse_headers = fuse_i.h fuse_kernel.h
-
- dev.o: $(fuse_headers)
-@@ -78,6 +63,18 @@
- file.o: $(fuse_headers)
- inode.o: $(fuse_headers)
-
-+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
-+
-+O_TARGET := fuse.o
-+
-+obj-y := $(fuse_objs)
-+obj-m := $(O_TARGET)
-+
-+-include $(TOPDIR)/Rules.make
-+
-+all-spec:
-+ $(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
-+
- else
-
- EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"