aboutsummaryrefslogtreecommitdiffstats
path: root/package/fuse/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-09 02:28:41 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-09 02:28:41 +0000
commit6b62c9b211655c184064e28f19b8315cc6ee4233 (patch)
tree30863380b421b1628341b19a341e86f48300dc7d /package/fuse/patches
parent80111df18a8085265176e364769e39d43a985c48 (diff)
downloadupstream-6b62c9b211655c184064e28f19b8315cc6ee4233.tar.gz
upstream-6b62c9b211655c184064e28f19b8315cc6ee4233.tar.bz2
upstream-6b62c9b211655c184064e28f19b8315cc6ee4233.zip
Add fuse package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@594 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/fuse/patches')
-rw-r--r--package/fuse/patches/101-kmod-build.patch59
-rw-r--r--package/fuse/patches/102-cflags-configure.patch22
2 files changed, 81 insertions, 0 deletions
diff --git a/package/fuse/patches/101-kmod-build.patch b/package/fuse/patches/101-kmod-build.patch
new file mode 100644
index 0000000000..5f4bee745d
--- /dev/null
+++ b/package/fuse/patches/101-kmod-build.patch
@@ -0,0 +1,59 @@
+--- fuse-2.2.1-orig/kernel/Makefile.in 2005-01-09 13:07:00.000000000 +0100
++++ fuse-2.2.1-1/kernel/Makefile.in 2005-04-06 14:48:59.000000000 +0200
+@@ -31,11 +31,11 @@
+ install-y: all
+ $(mkdir_p) $(DESTDIR)$(fusemoduledir)
+ $(INSTALL) -m 644 $(fusemodule) $(DESTDIR)$(fusemoduledir)/$(fusemodule)
+- -/sbin/depmod -a
++# -/sbin/depmod -a
+
+ uninstall-y:
+ rm -f $(DESTDIR)$(fusemoduledir)/$(fusemodule)
+- -/sbin/depmod -a
++# -/sbin/depmod -a
+
+ clean:
+ -rm -f $(fusemodule) *.o .*.cmd *.mod.c *.ko *.s */*.o
+@@ -54,23 +54,8 @@
+
+ ifeq ($(majver), 2.4)
+
+-CC = gcc
+-LD = ld
+-CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe
+-CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
+-
+ fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
+
+-SUFFIXES = .c .o .s
+-
+-all-spec: fuse.o
+-
+-.c.o:
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+-
+-fuse.o: $(fuse_objs)
+- $(LD) -r -o fuse.o $(fuse_objs)
+-
+ fuse_headers = fuse_i.h fuse_kernel.h
+
+ dev.o: $(fuse_headers)
+@@ -78,6 +63,18 @@
+ file.o: $(fuse_headers)
+ inode.o: $(fuse_headers)
+
++EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
++
++O_TARGET := fuse.o
++
++obj-y := $(fuse_objs)
++obj-m := $(O_TARGET)
++
++-include $(TOPDIR)/Rules.make
++
++all-spec:
++ $(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
++
+ else
+
+ EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
diff --git a/package/fuse/patches/102-cflags-configure.patch b/package/fuse/patches/102-cflags-configure.patch
new file mode 100644
index 0000000000..b358ab4ecd
--- /dev/null
+++ b/package/fuse/patches/102-cflags-configure.patch
@@ -0,0 +1,22 @@
+--- fuse-2.2.1-orig/configure 2005-03-08 15:48:57.000000000 +0100
++++ fuse-2.2.1-1/configure 2005-04-06 14:39:18.000000000 +0200
+@@ -9354,7 +9354,7 @@
+
+ fi
+
+-CFLAGS="-Wall -W -g -O2"
++[ -z "$CFLAGS" ] && CFLAGS="-Wall -W -g -O2"
+ CPPFLAGS="$CPPFLAGS -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DFUSE_USE_VERSION=22"
+
+ # Check whether --enable-kernel-module or --disable-kernel-module was given.
+--- fuse-2.2.1-orig/configure.in 2005-03-08 15:39:23.000000000 +0100
++++ fuse-2.2.1-1/configure.in 2005-04-06 14:39:20.000000000 +0200
+@@ -13,7 +13,7 @@
+ AC_SUBST(mkdir_p)
+ fi
+
+-CFLAGS="-Wall -W -g -O2"
++[ -z "$CFLAGS" ] && CFLAGS="-Wall -W -g -O2"
+ CPPFLAGS="$CPPFLAGS -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DFUSE_USE_VERSION=22"
+
+ AC_ARG_ENABLE(kernel-module,