aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-06-27 01:23:40 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-07-02 15:31:03 +0200
commitc54ec81c999e2de23d6a368b5f69dee68b24e9ff (patch)
tree4f9abcee6a74a82585a4de677e00e16f6eb47b0b /package/firmware
parent0d324c682cceb2576bbb2e31a6bf60f650f6794c (diff)
downloadupstream-c54ec81c999e2de23d6a368b5f69dee68b24e9ff.tar.gz
upstream-c54ec81c999e2de23d6a368b5f69dee68b24e9ff.tar.bz2
upstream-c54ec81c999e2de23d6a368b5f69dee68b24e9ff.zip
linux-firmware: ibt-firmware: install sfi/ddc files for AX210 card
When using an Intel AX210 card, the Bluetooth hci interface failed to start due to a missing "ibt-0041-0041.sfi" file. Bluetooth: hci0: Failed to load Intel firmware file intel/ibt-0041-0041.sfi (-2) A device specific configuration file (DDC) is also required: Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi Bluetooth: hci0: Waiting for firmware download to complete ... Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-0041-0041.ddc Bluetooth: hci0: Applying Intel DDC parameters completed Bluetooth: hci0: Firmware timestamp 2023.13 buildtype 1 build 62562 Fixes: #8558 Signed-off-by: Mathew McBride <matt@traverse.com.au> (cherry picked from commit fff6833d4c01205156f9431a111a51f96642b476)
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/Makefile2
-rw-r--r--package/firmware/linux-firmware/intel.mk2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index bed11fdbe1..63259cae36 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linux-firmware
PKG_VERSION:=20230515
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/package/firmware/linux-firmware/intel.mk b/package/firmware/linux-firmware/intel.mk
index 97694572b0..23b58358b4 100644
--- a/package/firmware/linux-firmware/intel.mk
+++ b/package/firmware/linux-firmware/intel.mk
@@ -3,6 +3,8 @@ define Package/ibt-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/intel
$(CP) \
$(PKG_BUILD_DIR)/intel/*.bseq \
+ $(PKG_BUILD_DIR)/intel/ibt*.sfi \
+ $(PKG_BUILD_DIR)/intel/ibt*.ddc \
$(1)/lib/firmware/intel
endef
$(eval $(call BuildPackage,ibt-firmware))