aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-04-04 21:48:42 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-07 11:11:43 +0200
commitc1f39adaf9692b4c01f226458c4b56d69f074481 (patch)
treecf671a53f7798aafc24dbd5a032ac15d38a18fbb /package/firmware
parent9a62b3977f7c2aa3ff3e25013069dee07c5296d7 (diff)
downloadupstream-c1f39adaf9692b4c01f226458c4b56d69f074481.tar.gz
upstream-c1f39adaf9692b4c01f226458c4b56d69f074481.tar.bz2
upstream-c1f39adaf9692b4c01f226458c4b56d69f074481.zip
ath11k-firmware: update to WLAN.HK.2.9.0.1-01385-QCAHKSWPL_SILICONZ-1
Current WLAN.HK.2.5.0.1 FW is quite old and buggy, but we had to hold off from updating to 2.6.0.1 and 2.7.0.1 as they had compatibility regressions, but now QCA finally released 2.9.0.1 FW which is working on all of the boards. So finally update IPQ8074 and QCN9074 FW to the latest WLAN.HK.2.9.0.1-01385-QCAHKSWPL_SILICONZ-1 firmware. In order to do so, we have to switch to using QCA-s QUIC repo instead of Kalle-s. QCA-s QUIC repo does not have BDF-s so we have to get the QCN9074 BDF from Kalles repo. Tested-by: Mireia Fernández Casals <meirin.f@gmail.com> # Xiaomi AX3600 Tested-by: Francisco G Luna <frangonlun@gmail.com> #Netgear WAX218 Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath11k-firmware/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/package/firmware/ath11k-firmware/Makefile b/package/firmware/ath11k-firmware/Makefile
index b3163cd1cb..fc7968a957 100644
--- a/package/firmware/ath11k-firmware/Makefile
+++ b/package/firmware/ath11k-firmware/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath11k-firmware
-PKG_SOURCE_DATE:=2022-12-14
-PKG_SOURCE_VERSION:=ab1229f94591ec4ffb16410e359b7f618be75a33
-PKG_MIRROR_HASH:=48a2526971e56a3be1c80b72cd82b9932c196b4ab9b7d5dc35117f0548a8fe57
+PKG_SOURCE_DATE:=2023-03-31
+PKG_SOURCE_VERSION:=a039049a9349722fa5c74185452ab04644a0d351
+PKG_MIRROR_HASH:=ed401e3f6e91d70565b3396139193f7e815f410db93700697205ac8ed1b828c5
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/kvalo/ath11k-firmware.git
+PKG_SOURCE_URL:=https://github.com/quic/upstream-wifi-fw.git
PKG_LICENSE_FILES:=LICENSE.qca_firmware
@@ -46,20 +46,31 @@ define Build/Compile
endef
+QCN9074_BOARD_REV:=8e140c65f36137714b6d8934e09dcd73cb05c2f6
+QCN9074_BOARD_FILE:=board-2.bin.$(QCN9074_BOARD_REV)
+
+define Download/qcn9074-board
+ URL:=https://github.com/kvalo/ath11k-firmware/raw/master/QCN9074/hw1.0/
+ URL_FILE:=board-2.bin
+ FILE:=$(QCN9074_BOARD_FILE)
+ HASH:=dbf0ca14aa1229eccd48f26f1026901b9718b143bd30b51b8ea67c84ba6207f1
+endef
+$(eval $(call Download,qcn9074-board))
+
define Package/ath11k-firmware-ipq8074/install
$(INSTALL_DIR) $(1)/lib/firmware/IPQ8074
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/IPQ8074/hw2.0/2.5.0.1/WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1/* \
+ $(PKG_BUILD_DIR)/ath11k-firmware/IPQ8074/hw2.0/testing/2.9.0.1/WLAN.HK.2.9.0.1-01385-QCAHKSWPL_SILICONZ-1/* \
$(1)/lib/firmware/IPQ8074/
endef
define Package/ath11k-firmware-qcn9074/install
$(INSTALL_DIR) $(1)/lib/firmware/ath11k/QCN9074/hw1.0
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCN9074/hw1.0/2.5.0.1/WLAN.HK.2.5.0.1-01208-QCAHKSWPL_SILICONZ-1/* \
+ $(PKG_BUILD_DIR)/ath11k-firmware/QCN9074/hw1.0/testing/2.9.0.1/WLAN.HK.2.9.0.1-01385-QCAHKSWPL_SILICONZ-1/* \
$(1)/lib/firmware/ath11k/QCN9074/hw1.0/
$(INSTALL_BIN) \
- $(PKG_BUILD_DIR)/QCN9074/hw1.0/board-2.bin $(1)/lib/firmware/ath11k/QCN9074/hw1.0/board-2.bin
+ $(DL_DIR)/$(QCN9074_BOARD_FILE) $(1)/lib/firmware/ath11k/QCN9074/hw1.0/board-2.bin
endef
$(eval $(call BuildPackage,ath11k-firmware-ipq8074))