aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-10-22 20:38:49 +0200
committerChristian Lamparter <chunkeey@gmail.com>2021-10-30 16:32:59 +0200
commitfd717f54beaaa791123cd146af4e790cc19a05c6 (patch)
tree45636a94f7c9403ac042b1f97ccfb85ef780fa39 /package/firmware
parent4c8dd973ef8e76f9fc622f0baab981769c89b601 (diff)
downloadupstream-fd717f54beaaa791123cd146af4e790cc19a05c6.tar.gz
upstream-fd717f54beaaa791123cd146af4e790cc19a05c6.tar.bz2
upstream-fd717f54beaaa791123cd146af4e790cc19a05c6.zip
ipq40xx: detangle ath10k-board-qca4019 from ath10k-firmware-qca4019*
Back in the day, the board-2.bin came with ath10k-firmware-qca4019. This changed with commit c3b2efaf24b5 ("linux-firmware: ath10k: add board firmware packages") which placed the board-2.bin into a separate package: ath10k-board-qca4019. This was great, because it addressed one of the caveat of the original ipq-wifi package: commit fa03d441e96e ("firmware: add custom IPQ wifi board definitions") | 2. updating ath10k-firmware-qca4019 will also replace | the board-2.bin. For this cases the user needs to | manually reinstall the wifi-board package once the | ath10k-firmware-qca4019 is updated. This could be extended further so that ipq-wifi packages no longer use "install-override" and the various QCA4019 variants list the ath10k-board-qca4019 as a CONFLICT package. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-ct-firmware/Makefile3
-rw-r--r--package/firmware/linux-firmware/qca_ath10k.mk2
2 files changed, 1 insertions, 4 deletions
diff --git a/package/firmware/ath10k-ct-firmware/Makefile b/package/firmware/ath10k-ct-firmware/Makefile
index 4fd7266f22..b210f1a5e4 100644
--- a/package/firmware/ath10k-ct-firmware/Makefile
+++ b/package/firmware/ath10k-ct-firmware/Makefile
@@ -292,7 +292,6 @@ $(Package/ath10k-ct-firmware-default)
CATEGORY:=Firmware
PROVIDES:=ath10k-firmware-qca4019
CONFLICTS:=ath10k-firmware-qca4019
- DEPENDS:=+ath10k-board-qca4019
endef
define Package/ath10k-firmware-qca4019-ct-full-htt
$(Package/ath10k-ct-firmware-default)
@@ -307,7 +306,6 @@ $(Package/ath10k-ct-firmware-default)
ath10k-firmware-qca4019-ct \
ath10k-firmware-qca4019-ct-htt
DEPENDS:=\
- +ath10k-board-qca4019 \
+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca4019-ct-htt
@@ -322,7 +320,6 @@ $(Package/ath10k-firmware-default)
ath10k-firmware-qca4019 \
ath10k-firmware-qca4019-ct
DEPENDS:=\
- +ath10k-board-qca4019 \
+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
endef
diff --git a/package/firmware/linux-firmware/qca_ath10k.mk b/package/firmware/linux-firmware/qca_ath10k.mk
index d30487441e..d2c709af7a 100644
--- a/package/firmware/linux-firmware/qca_ath10k.mk
+++ b/package/firmware/linux-firmware/qca_ath10k.mk
@@ -33,7 +33,7 @@ define Package/ath10k-board-qca4019/install
$(1)/lib/firmware/ath10k/QCA4019/hw1.0/
endef
$(eval $(call BuildPackage,ath10k-board-qca4019))
-Package/ath10k-firmware-qca4019 = $(call Package/firmware-default,ath10k qca4019 firmware,+ath10k-board-qca4019)
+Package/ath10k-firmware-qca4019 = $(call Package/firmware-default,ath10k qca4019 firmware)
define Package/ath10k-firmware-qca4019/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA4019/hw1.0
$(INSTALL_DATA) \