aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorYutang Jiang <yutang.jiang@nxp.com>2016-12-08 00:07:42 +0800
committerJohn Crispin <john@phrozen.org>2016-12-12 09:57:40 +0100
commitad907e1c03a3a1a236f4836cee085d085f280c8d (patch)
tree6280b4318cb40d6e567a23a250f0d9f564787761 /package/firmware
parent76fa771a784312f789f5de3d2216c1765a901818 (diff)
downloadupstream-ad907e1c03a3a1a236f4836cee085d085f280c8d.tar.gz
upstream-ad907e1c03a3a1a236f4836cee085d085f280c8d.tar.bz2
upstream-ad907e1c03a3a1a236f4836cee085d085f280c8d.zip
layerscape: add 64b/32b target for ls1046ardb device
Add support for NXP layerscape ls1046ardb 64b/32b Dev board. LS1046ARDB Specification: ------------------------- Memory subsystem: * 8GByte DDR4 SDRAM (64bit bus) * 512 Mbyte NAND flash * Two 64 Mbyte high-speed SPI flash * SD connector to interface with the SD memory card * On-board 4G eMMC Ethernet: * Two XFI 10G ports * Two SGMII ports * Two RGMII ports PCIe: * PCIe1 (SerDes2 Lane0) to miniPCIe slot * PCIe2 (SerDes2 Lane1) to x2 PCIe slot * PCIe3 (SerDes2 Lane2) to x4 PCIe slot * USB 3.0: one super speed USB 3.0 type A port, one Micro-AB port * UART: supports two UARTs up to 115200 bps for console Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/fman-ucode/Makefile8
-rw-r--r--package/firmware/rcw/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/package/firmware/fman-ucode/Makefile b/package/firmware/fman-ucode/Makefile
index 216882f664..b0b29ed9cf 100644
--- a/package/firmware/fman-ucode/Makefile
+++ b/package/firmware/fman-ucode/Makefile
@@ -35,8 +35,14 @@ define fman/ls1043ardb
CONFIG=fsl_fman_ucode_ls1043_r1.0_108_4_5.bin
endef
+define fman/ls1046ardb
+ TITLE=FMAN UCODE $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
+ CONFIG=fsl_fman_ucode_t2080_r1.1_106_4_18.bin
+endef
+
FMANS := \
- ls1043ardb
+ ls1043ardb \
+ ls1046ardb
define Package/fman/template
define Package/fman-layerscape-$(1)
diff --git a/package/firmware/rcw/Makefile b/package/firmware/rcw/Makefile
index a412fd9f74..8dfbfe9546 100644
--- a/package/firmware/rcw/Makefile
+++ b/package/firmware/rcw/Makefile
@@ -16,7 +16,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/fsl-jyt/rcw.git
-PKG_SOURCE_VERSION:=e101d1207f402c7b761990a3e6681fdae8f253e3
+PKG_SOURCE_VERSION:=17e09e19bd5cf94e5ebc84916b4607743c29723e
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -35,6 +35,11 @@ define rcw/ls1043ardb
CONFIG=ls1043ardb-rcw.bin
endef
+define rcw/ls1046ardb
+ TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
+ CONFIG=ls1046ardb-rcw.bin
+endef
+
define rcw/ls1012ardb
TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 64b/32b Dev Board
CONFIG=ls1012ardb-rcw.bin
@@ -42,6 +47,7 @@ endef
RCWS := \
ls1043ardb \
+ ls1046ardb \
ls1012ardb
define Package/rcw/template