aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@gmail.com>2016-06-19 23:49:16 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:21 +0200
commit76662637fadba33d698c60f754e67645edf3ce50 (patch)
treeb480985d0bf2ea90c78f0e1a44984b54476c314e /package/firmware
parenta7c8112a0ff609e85bfd58e21efec6322f946285 (diff)
downloadupstream-76662637fadba33d698c60f754e67645edf3ce50.tar.gz
upstream-76662637fadba33d698c60f754e67645edf3ce50.tar.bz2
upstream-76662637fadba33d698c60f754e67645edf3ce50.zip
linux-firmware: add ath6k firmware to package
Systems which include the ath6k chipset need to have the firmware included in the image. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/qca.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/qca.mk b/package/firmware/linux-firmware/qca.mk
index 7ad27ef388..0a809d1a21 100644
--- a/package/firmware/linux-firmware/qca.mk
+++ b/package/firmware/linux-firmware/qca.mk
@@ -7,6 +7,16 @@ define Package/ar3k-firmware/install
endef
$(eval $(call BuildPackage,ar3k-firmware))
+
+Package/ath6k-firmware = $(call Package/firmware-default,AR600X firmware)
+define Package/ath6k-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath6k
+ $(CP) \
+ $(PKG_BUILD_DIR)/ath6k/* \
+ $(1)/lib/firmware/ath6k
+endef
+$(eval $(call BuildPackage,ath6k-firmware))
+
Package/ath9k-htc-firmware = $(call Package/firmware-default,AR9271/AR7010 firmware)
define Package/ath9k-htc-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/ath9k_htc