aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-05-24 20:47:46 -0700
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:11:03 +0100
commit31f935edafa4cbd793934e0591cc278e0ed0564a (patch)
tree8e90319009a4be2c923cb5ea807ea3cb8d6c2246 /package/firmware
parent5826efd18ca970462cefa7f82edcd671493d32fb (diff)
downloadupstream-31f935edafa4cbd793934e0591cc278e0ed0564a.tar.gz
upstream-31f935edafa4cbd793934e0591cc278e0ed0564a.tar.bz2
upstream-31f935edafa4cbd793934e0591cc278e0ed0564a.zip
ath10k-firmware: Fix QCA6174 support
Currently when installing the firmware, a bunch of files and directories that the ath10k driver does not look for are created. The package now installs firmware for both hw 2.1 and 3.0 devices. 2.1 is abandonware but may be useful to keep. 3.0 firmware was tested on a Killer 1535 to be relatively stable with 802.11w disabled. 802.11w causes multiple firmware crashes but that's true of other ath10k firmwares as well. Signed-off-by: Rosen Penev <rosenp@gmail.com> (backported and squashed from 27eab4fa578d696ab55b6264a1b35fad6488b664, d0fbe1956b3b9f07b6dcb54a8ed43a4904581e1d, e191c7ee797c8b3458eb9791212a56b16febeeb4) Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index eaee0ebc51..c2b4000671 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -438,8 +438,20 @@ define Package/ath10k-firmware-qca988x/install
endef
define Package/ath10k-firmware-qca6174/install
- $(INSTALL_DIR) $(1)/lib/firmware/ath10k
- $(CP) $(PKG_BUILD_DIR)/QCA6174 $(1)/lib/firmware/ath10k/
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA6174/hw2.1
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA6174/hw2.1/board-2.bin \
+ $(1)/lib/firmware/ath10k/QCA6174/hw2.1/
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA6174/hw2.1/firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1 \
+ $(1)/lib/firmware/ath10k/QCA6174/hw2.1/firmware-5.bin
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA6174/hw3.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA6174/hw3.0/board-2.bin \
+ $(1)/lib/firmware/ath10k/QCA6174/hw3.0/
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA6174/hw3.0/4.4.1.c1/firmware-6.bin_RM.4.4.1.c1-00042-QCARMSWP-1 \
+ $(1)/lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin
endef
define Package/ath10k-firmware-qca99x0/install