aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-05-08 08:51:46 +0200
committerJohn Crispin <john@phrozen.org>2017-06-27 11:47:07 +0200
commit6da4f03f026e0375c5d14628d2ffe1bebd741c47 (patch)
tree380d3eff7b957d42dbb19b34ac9bff0985c3f902 /package/firmware
parentf80963d4d18d67c3190d40b7eadaa0e427ccbf7b (diff)
downloadupstream-6da4f03f026e0375c5d14628d2ffe1bebd741c47.tar.gz
upstream-6da4f03f026e0375c5d14628d2ffe1bebd741c47.tar.bz2
upstream-6da4f03f026e0375c5d14628d2ffe1bebd741c47.zip
ath10k-firmware: add qca9888 firmware
ath10k-firmware: add qca9888 firmware the firmware files for qca9888 were previously not packaged. add the meta information for doing so. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index d33f650db3..16d77a398f 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -32,6 +32,11 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA9887 devices
endef
+define Package/ath10k-firmware-qca9888
+$(Package/ath10k-firmware-default)
+ TITLE:=ath10k firmware for QCA9888 devices
+endef
+
define Package/ath10k-firmware-qca9887-ct
$(Package/ath10k-firmware-default)
TITLE:=ath10k-CT firmware for QCA9887 devices
@@ -256,6 +261,19 @@ define Package/ath10k-firmware-qca9887/install
$(1)/lib/firmware/ath10k/QCA9887/hw1.0/board.bin
endef
+define Package/ath10k-firmware-qca9888/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9888/hw2.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA9888/hw2.0/board-2.bin \
+ $(1)/lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA9888/hw2.0/board-2.bin \
+ $(1)/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA9888/hw2.0/firmware-5.bin_10.4-3.2-00072 \
+ $(1)/lib/firmware/ath10k/QCA9888/hw2.0/firmware-5.bin
+endef
+
define Package/ath10k-firmware-qca988x/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
$(INSTALL_DATA) \
@@ -351,6 +369,7 @@ define Package/ath10k-firmware-qca9888-ct/install
endef
$(eval $(call BuildPackage,ath10k-firmware-qca9887))
+$(eval $(call BuildPackage,ath10k-firmware-qca9888))
$(eval $(call BuildPackage,ath10k-firmware-qca988x))
$(eval $(call BuildPackage,ath10k-firmware-qca99x0))
$(eval $(call BuildPackage,ath10k-firmware-qca6174))