aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorPavel Kubelun <be.dissent@gmail.com>2016-12-21 15:41:19 +0300
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:48:52 +0100
commit36167ae46c62caa9e0409423ecd1aaa4d18dad1c (patch)
treee2ebb4e7febf0dcfb1298dc11241fa6080340508 /package/firmware
parent4ee4c24092b18c7374b32057bbf098484f8ce9d4 (diff)
downloadupstream-36167ae46c62caa9e0409423ecd1aaa4d18dad1c.tar.gz
upstream-36167ae46c62caa9e0409423ecd1aaa4d18dad1c.tar.bz2
upstream-36167ae46c62caa9e0409423ecd1aaa4d18dad1c.zip
ath10k-firmware: update board data for qca9984
Current board-2.bin file for qca9984 in Kvalo's repo is from branch 10.4-3.2, while board-2.bin file in code-aurora repo is newer and corresponds to the branch 10.4-3.3, the same as recently updated firmware. Considering that it's better to have all parts from the same branch we are updating board-2.bin as well. Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 55d14ff590..5091663953 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -177,10 +177,21 @@ define Download/qca99x0-board
endef
$(eval $(call Download,qca99x0-board))
+QCA9984_BOARD_REV:=deb1832c56c706d0f6cb539113e09f0daaa52b5f
+QCA9984_BOARD_FILE:=board-2.bin
+QCA9984_BOARD_FILE_DL:=$(QCA9984_BOARD_FILE).$(QCA9984_BOARD_REV)
QCA9984_FIRMWARE_REV:=deb1832c56c706d0f6cb539113e09f0daaa52b5f
QCA9984_FIRMWARE_FILE:=firmware-5.bin_10.4-3.3-00102
QCA9984_FIRMWARE_FILE_DL:=$(QCA9984_FIRMWARE_FILE).$(QCA9984_FIRMWARE_REV)
+define Download/ath10k-qca9984-board
+ URL:=https://source.codeaurora.org/quic/qsdk/oss/firmware/ath10k-firmware/plain/ath10k/QCA9984/hw1.0/
+ URL_FILE:=$(QCA9984_BOARD_FILE)?id=$(QCA9984_BOARD_REV)
+ FILE:=$(QCA9984_BOARD_FILE_DL)
+ HASH:=6a79ff0e8cc71549e771b41dbb7dad862d8e29da852f8aff25ce1e4bd5ea263e
+endef
+$(eval $(call Download,ath10k-qca9984-board))
+
define Download/ath10k-qca9984-firmware
URL:=https://source.codeaurora.org/quic/qsdk/oss/firmware/ath10k-firmware/plain/ath10k/QCA9984/hw1.0/
URL_FILE:=$(QCA9984_FIRMWARE_FILE)?id=$(QCA9984_FIRMWARE_REV)
@@ -260,7 +271,7 @@ define Package/ath10k-firmware-qca9984/install
../../cal-pci-0000:01:00.0.bin \
$(1)/lib/firmware/ath10k/QCA9984/hw1.0/board.bin
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
+ $(DL_DIR)/$(QCA9984_BOARD_FILE_DL) \
$(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
$(INSTALL_DATA) \
$(DL_DIR)/$(QCA9984_FIRMWARE_FILE_DL) \